Rate Limit = (Bandwidth*0.90) - (Phones*0.15)


Download Bandwidth in Mbps:
Upload Bandwidth in Mbps:
Total Number of Phones:

Update MikroTik QoS & Rate Limiting Script


  • Enter Download Bandwidth in Mbps
  • Enter Upload Bandwidth in Mbps
  • Enter Total Number of Phones
  • Click the Update MikroTik QoS & Rate Limiting Script button
  • Highlight, right-click, and Copy the script
  • Launch WinBox and connect to the MikroTik router
  • Click the New Terminal button
  • Right-click, Paste the script, and press Enter

Internet Connection Notes


  • Internet connection will support up to 0 phones
  • Total available bandwidth is 0/0 Mbps
  • Reserved VoIP bandwidth is 0/0 Mbps
  • Reserved data bandwidth is 0.00/0.00 Mbps
/ip firewall address-list

add address=208.77.63.131 list="SBC IP's"
add address=208.93.135.178 list="SBC IP's"

/ip firewall mangle

add action=mark-connection chain=forward comment="Mark Incoming VoIP Connections" connection-state=new new-connection-mark=VoIP src-address-list="SBC IP's"
add action=mark-packet chain=forward connection-mark=VoIP new-packet-mark=VoIP
add action=mark-connection chain=forward comment="Mark Outgoing VoIP Connections" connection-state=new dst-address-list="SBC IP's" new-connection-mark=VoIP
add action=mark-packet chain=forward connection-mark=VoIP new-packet-mark=VoIP
add action=mark-connection chain=forward comment="Mark Other Traffic" connection-mark=no-mark new-connection-mark=Other
add action=mark-packet chain=forward connection-mark=Other new-packet-mark=Other

/queue tree

add comment="Set to 100% of Upload Bandwidth (0 Mbps)" max-limit=0M name="Prioritized Upload Traffic" parent=ether1-gateway queue=default
add comment="Set to 100% of Download Bandwidth (0 Mbps)" max-limit=0M name="Prioritized Download Traffic" parent=ether2-master-local queue=default
add comment="Rate Limit Standard Upload Traffic (90% of Upload Bandwidth - 0 Phones @ 0.15 Mbps)" max-limit=0.00M name="Standard Upload Traffic" parent=ether1-gateway queue=default
add comment="Rate Limit Standard Download Traffic (90% of Download Bandwidth - 0 Phones @ 0.15 Mbps)" max-limit=0.00M name="Standard Download Traffic" parent=ether2-master-local queue=default
add name="VoIP Traffic Up" packet-mark=VoIP parent="Prioritized Upload Traffic" priority=1 queue=default
add name="VoIP Traffic Down" packet-mark=VoIP parent="Prioritized Download Traffic" priority=1 queue=default
add name="Other Traffic Up" packet-mark=Other parent="Standard Upload Traffic" priority=2 queue=default
add name="Other Traffic Down" packet-mark=Other parent="Standard Download Traffic" priority=2 queue=default

/